Reports a bounding box of the geometry that this server submits for drawing.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- dBView
- Type: Autodesk.Revit.DBView
The view where rendering will occur. If this argument is a null reference (Nothing in Visual Basic), a view-independent bounding box should be reported.
Return Value
The bounding box as an Outline.Remarks
Revit uses the bounding box when navigating views, e.g., when a Zoom to Fit command is issued. The reported bounding box does not have to be tight. However, there may be unintended side-effects if the box is inconsistent with the submitted geometry.