Adds a subfolder to the folder path with the given name and icon type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folderName
- Type: SystemString
The name of the folder.
- iconPath
- Type: SystemString
Icon path.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The folderName is not a valid folder name used to display in Revit external resource browse UI. The name should be a unique non-empty short name and it should not contain any invalid character of \\/:*?"<>|. The length of combined path(server name + folder path) should not exceeds 259. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |