TimeInterval Property


Identifies the time interval between animation frames.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public SunStudyTimeInterval TimeInterval { get; set; }
Visual Basic
Public Property TimeInterval As SunStudyTimeInterval
	Get
	Set
Visual C++
public:
property SunStudyTimeInterval TimeInterval {
	SunStudyTimeInterval get ();
	void set (SunStudyTimeInterval value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: the time interval value interval is not valid for the current SunAndShadowType.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also