Offsets the given part face in the direction that points out of the solid shape with the specified amount. Negative value will offset the face into the solid shape.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DBFace
The face to offset.
- offset
- Type: SystemDouble
The magnitude of the offset.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | face does not belong to the part. -or- The face to be offset should be planar and satisfy constraints of its parent element |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |