ScheduleFilter Constructor (ScheduleFieldId, ScheduleFilterType, String)


Creates a new ScheduleFilter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public ScheduleFilter(
	ScheduleFieldId fieldId,
	ScheduleFilterType filterType,
	string value
)
Visual Basic
Public Sub New ( _
	fieldId As ScheduleFieldId, _
	filterType As ScheduleFilterType, _
	value As String _
)
Visual C++
public:
ScheduleFilter(
	ScheduleFieldId^ fieldId, 
	ScheduleFilterType filterType, 
	String^ value
)

Parameters

fieldId
Type: Autodesk.Revit.DBScheduleFieldId
The ID of the field used to filter the schedule.
filterType
Type: Autodesk.Revit.DBScheduleFilterType
The filter type.
value
Type: SystemString
The filter value for a filter using a string value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also