DrawPoint Method


Adds a point to the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public SlabShapeVertex DrawPoint(
	XYZ location
)
Visual Basic
Public Function DrawPoint ( _
	location As XYZ _
) As SlabShapeVertex
Visual C++
public:
SlabShapeVertex^ DrawPoint(
	XYZ^ location
)

Parameters

location
Type: Autodesk.Revit.DBXYZ
The location of the point.

Return Value

The newly created vertex.

Remarks

If the input location is not on the top face of the slab, this function will return a null reference (Nothing in Visual Basic). Drawing a point on boundary crease may increase the number of creases. This method will regenerate the document even in manual regeneration mode.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the location is a null reference (Nothing in Visual Basic).

See Also