Sets a group of user-created worksets to open.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- worksetsToOpen
- Type: System.Collections.GenericIListWorksetId
The group of user-created worksets to open. Non-user-created worksets and invalid workset ids will be ignored.
Remarks
Calling this method on a configuration created with options other than WorksetConfigurationOption.OpenAllWorksets will set these worksets to be explicitly opened. If all worksets are set to open, the configuration will be unchanged. Worksets other than the inputs are unaffected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |