GetPath Method


Gets the railing path.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public IList<Curve> GetPath()
Visual Basic
Public Function GetPath As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ GetPath()

Return Value

The curve array of the railing path.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInapplicableDataException The railing has incorrect internal data.

See Also