Creates a new energy analysis detailed model.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document that contains the physical model of the building.
- options
- Type: Autodesk.Revit.DB.AnalysisEnergyAnalysisDetailModelOptions
The options to control the calculation rules.
Return Value
The created model instance.Remarks
The generated energy model is always returned in world coordinates. The method TransformModel() transforms all surfaces in the model according to ground plane, shared coordinates and true north. The EnergyModelType in argument EnergyAnalysisDetailModelOptions indicates whether the generated energy model is based on rooms/spaces or building elements. The default value is EnergyModelType.SpatialElement.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | An EnergyAnalysisDetailModel cannot be created if EnergyModelType.BuildingElement is input and AnalysisMode.ConceptualMasses is set in EnergyDataSettings (these values are incompatible). -or- Throws if there are no valid spatial bounding elements, or no valid spatial elements in the document. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Failed to create the energy analysis detail model. |
Autodesk.Revit.ExceptionsOperationCanceledException | Throws if user aborted the energy analysis detail model creation. |