Gets the default parameter name that will be used when creating a key schedule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to which the new schedule will be added.
- categoryId
- Type: Autodesk.Revit.DBElementId
The ID of the category of elements that the schedule's keys will be associated with.
Return Value
The default parameter name.Remarks
See ViewSchedule.KeyScheduleParameterName for details.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | document is not a project document. -or- categoryId is not a valid category for a key schedule. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |