Print Method (View)


Print this view with the given view template and using the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void Print(
	View viewTemplate
)
Visual Basic
Public Sub Print ( _
	viewTemplate As View _
)
Visual C++
public:
void Print(
	View^ viewTemplate
)

Parameters

viewTemplate
Type: Autodesk.Revit.DBView
The view template which apply to the view.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when the view cannot be printed.

See Also