CreateGreaterOrEqualRule Method (ElementId, String, Boolean)


Creates a filter rule that determines whether strings from the document are greater than or equal to a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public static FilterRule CreateGreaterOrEqualRule(
	ElementId parameter,
	string value,
	bool caseSensitive
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")> _
Public Shared Function CreateGreaterOrEqualRule ( _
	parameter As ElementId, _
	value As String, _
	caseSensitive As Boolean _
) As FilterRule
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2023 and may be removed in a future version of Revit. Please use the constructor without the `caseSensitive` argument instead.")]
public:
static FilterRule^ CreateGreaterOrEqualRule(
	ElementId^ parameter, 
	String^ value, 
	bool caseSensitive
)

Parameters

parameter
Type: Autodesk.Revit.DBElementId
A string-typed parameter used to get values from the document for a given element.
value
Type: SystemString
The user-supplied string value against which values from the document will be compared.
caseSensitive
Type: SystemBoolean
If true, the string comparison will be case-sensitive.

Remarks

For strings, a value is "greater" than another if it would appear after the other in an alphabetically-sorted list.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also