Gets a space containing the point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- point
- Type: Autodesk.Revit.DBXYZ
Point to be checked.
Return Value
The space containing the point.Remarks
Surveys only the spaces from the final phase of the project. The first one found will be returned. If there is no space containing the point, it returns a null reference (Nothing in Visual Basic).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the point is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the coordinates of the point are not number or are Double::MaxValue or Double::MinValue. |