An affine transform of 1D Euclidean space.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
An affine transform is a linear transform plus a translation (which may be zero). 1D space is tranformed according to the following formula: t -> A*t + B where A and B are constants. Some functions only accept certain kinds of transform (e.g., rigid motion, conformal, non-singular, etc.).
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBTransform1D
Autodesk.Revit.DBTransform1D