Start Method


Starts a sketch edit mode.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void Start(
	ElementId sketchId
)
Visual Basic
Public Sub Start ( _
	sketchId As ElementId _
)
Visual C++
public:
void Start(
	ElementId^ sketchId
)

Parameters

sketchId
Type: Autodesk.Revit.DBElementId
The Sketch element to be edited.

Remarks

The application will need to start a transaction to actually make changes to the Sketch element. SketchEditScope can only be started when there is no transaction active, thus it does not work for commands running in automatic transaction mode.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ElementId sketchId does not represent a Sketch. -or- Sketch does not support editing. -or- Failed to start the sketch edit mode.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This SketchEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document.

See Also