IsNonSolid Method


Makes sure that the input geometry object is not a Solid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public static bool IsNonSolid(
	GeometryObject geometry
)
Visual Basic
Public Shared Function IsNonSolid ( _
	geometry As GeometryObject _
) As Boolean
Visual C++
public:
static bool IsNonSolid(
	GeometryObject^ geometry
)

Parameters

geometry
Type: Autodesk.Revit.DBGeometryObject
Geometry object to be validated.

Return Value

True if the supplied geometry object is not a Solid.

Remarks

This validation is different than negating IsSolid().

See Also