Checks that an ElementFilter is acceptable for use in defining the filtering rules for a given list of categories (i.e., for view filtering).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDocument
- Type: Autodesk.Revit.DBDocument
The document in which to create the ParameterFilterElement.
- categories
- Type: System.Collections.GenericISetElementId
The categories for the new ParameterFilterElement.
- elementFilter
- Type: Autodesk.Revit.DBElementFilter
The ElementFilter to validate.
Remarks
ElementFilter is either an ElementParameterFilter or an ElementLogicalFilter representing a Boolean combination of ElementParameterFilters. In addition, we check that each ElementParameterFilter satisfies the following conditions: Its array of FilterRules is not empty and contains:
- Any number of FilterRules of type FilterValueRule, FilterInverseRule, and SharedParameterApplicableRule or
- Exactly one FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement or
- Exactly two rules: the first one is a FilterCategoryRule containing only one category from categories stored by this ParameterFilterElement and the second one is a FilterRule of type FilterValueRule, FilterInverseRule, or SharedParameterApplicableRule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |