EnergyModelType Property


It indicates whether the energy model is based on rooms/spaces or building elements.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public EnergyModelType EnergyModelType { get; set; }
Visual Basic
Public Property EnergyModelType As EnergyModelType
	Get
	Set
Visual C++
public:
property EnergyModelType EnergyModelType {
	EnergyModelType get ();
	void set (EnergyModelType value);
}

Remarks

The default value is EnergyModelType::SpatialElement.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also