AddPoints Method


Inserts multiple IndexPoint instances into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void AddPoints(
	IList<IndexPoint> points
)
Visual Basic
Public Sub AddPoints ( _
	points As IList(Of IndexPoint) _
)
Visual C++
public:
void AddPoints(
	IList<IndexPoint^>^ points
)

Parameters

points
Type: System.Collections.GenericIListIndexPoint
The points to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also