AddEdge Method


Add a new edge to the geometry being built. The BRepBuilder uses edges only to store edge geometry and to track pairs of co-edges that share an edge.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public BRepBuilderGeometryId AddEdge(
	BRepBuilderEdgeGeometry edgeGeom
)
Visual Basic
Public Function AddEdge ( _
	edgeGeom As BRepBuilderEdgeGeometry _
) As BRepBuilderGeometryId
Visual C++
public:
BRepBuilderGeometryId^ AddEdge(
	BRepBuilderEdgeGeometry^ edgeGeom
)

Parameters

edgeGeom
Type: Autodesk.Revit.DBBRepBuilderEdgeGeometry
Information specifying the edge's geometry.

Return Value

Id of the edge, to be used in calls to other BRepBuilder methods such as AddCoEdge().

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input edge geometry was invalid.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details.

See Also