Unmap Method


Unmaps the buffer, so that it can be used for rendering.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void Unmap()
Visual Basic
Public Sub Unmap
Visual C++
public:
void Unmap()

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException This VertexBuffer is not available because Revit is not currently rendering. In general, this VertexBuffer must be used in the scope of the RenderScene() callback of IDirectContext3DServer.

See Also