GetDeformedShapeSettings Method


Get deformed shape settings object from the style.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public AnalysisDisplayDeformedShapeSettings GetDeformedShapeSettings()
Visual Basic
Public Function GetDeformedShapeSettings As AnalysisDisplayDeformedShapeSettings
Visual C++
public:
AnalysisDisplayDeformedShapeSettings^ GetDeformedShapeSettings()

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException deformed shape settings were not created with the object.

See Also