Creates an object which wraps the arguments of NewFamilyInstance() for batch creation.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- location
- Type: Autodesk.Revit.DBXYZ
The physical location where the instance is to be placed.
- symbol
- Type: Autodesk.Revit.DBFamilySymbol
A FamilySymbol object that represents the type of the instance that is to be inserted.
- referenceDirection
- Type: Autodesk.Revit.DBXYZ
A vector that dictates the direction of certain family instances.
- host
- Type: Autodesk.Revit.DBElement
The object into which the family instance is to be inserted, often known as the host.
- structuralType
- Type: Autodesk.Revit.DB.StructureStructuralType
If structural then specify the type of the component.