Gets the Rebar Shape id for the bar with index barPositionIndex.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- barPositionIndex
- Type: SystemInt32
An index between 0 and (NumberOfBarPositions-1).
Return Value
Gets the ElementId of the Rebar Shape for the bar with index barPositionIndex.Remarks
If this function is called for a bar that isn't included, this function will throw exception.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | barPositionIndex is not in the range [ 0, NumberOfBarPositions-1 ]. -or- The bar at barPositionIndex index is excluded. |