Create a new conduit ConnectorElement.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to add the connector to.
- planarFace
- Type: Autodesk.Revit.DBReference
The planar face to place the connector on.
Return Value
The conduit ConnectorElement.Remarks
Regenerates the document.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The reference is not a planar face. -or- document is not a family document. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Connector creation is not allowed in this family. |