PaperSize Property


The page size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public PaperSize PaperSize { get; set; }
Visual Basic
Public Property PaperSize As PaperSize
	Get
	Set
Visual C++
public:
property PaperSize^ PaperSize {
	PaperSize^ get ();
	void set (PaperSize^ value);
}

Remarks

User can select the candidate via PaperSizes and then set the Page source of the Print Setting.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when the input argument is invalid for current printer.

See Also