GetStairsOnLevel Method


Gets the individual stairs or stairs group on the given base level.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public Stairs GetStairsOnLevel(
	ElementId levelId
)
Visual Basic
Public Function GetStairsOnLevel ( _
	levelId As ElementId _
) As Stairs
Visual C++
public:
Stairs^ GetStairsOnLevel(
	ElementId^ levelId
)

Parameters

levelId
Type: Autodesk.Revit.DBElementId
The base level id.

Return Value

The id of stairs element on the given level.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also