GetElementsThatFailed Method


Gets the set of fabrication parts that had failures due to either there was no corresponding part in the service, the size was out of range, or a connection could not be made.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2018.2

Syntax

C#
public ISet<ElementId> GetElementsThatFailed()
Visual Basic
Public Function GetElementsThatFailed As ISet(Of ElementId)
Visual C++
public:
ISet<ElementId^>^ GetElementsThatFailed()

Remarks

This set of element identifiers is only available after the ChangeService or ChangeSize method has been invoked, and returns FabricationNetworkChangeServiceResult::Enum::PartialFailure.

See Also