Creates a new radial array element from a single element based on an input rotation axis.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DBDocument
The document.
- dBView
- Type: Autodesk.Revit.DBView
The view. If it is a 2d view, translation vector must be in the view plane if the element is a view-specific element.
- id
- Type: Autodesk.Revit.DBElementId
The element to array. The position of the rotation axis is determined by the center of the element's bounding boxes.
- count
- Type: SystemInt32
The number of array members to create. The accepted range is from 3 to 200.
- axis
- Type: Autodesk.Revit.DBLine
The rotation axis.
- angle
- Type: SystemDouble
The angle in radians of the rotation.
- anchorMember
- Type: Autodesk.Revit.DBArrayAnchorMember
Indicates if the translation vector specifies the location of the second member of the array, or the last member of the array.
Return Value
The new radial array element.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The element id does not exist in the document -or- id is not arrayable. -or- count must be between 3 and 200. -or- The view is invalid for specific view elements array. -or- The rotation axis is invalid to array the element. -or- Angle value must be not zero. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInvalidOperationException | Failed to create the radial array. |