IsRebarInSection Method


Identifies if this RebarInSystem is cut by the view plane of the given view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015

Syntax

C#
public bool IsRebarInSection(
	View dBView
)
Visual Basic
Public Function IsRebarInSection ( _
	dBView As View _
) As Boolean
Visual C++
public:
bool IsRebarInSection(
	View^ dBView
)

Parameters

dBView
Type: Autodesk.Revit.DB View
The view.

Return Value

True if this RebarInSystem is cut by the view plane, false otherwise.

Remarks

This method applies only for elevations and sections. For any other view types will return false.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also