Splits the region which contains the specified grid point by a line with the specified direction.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- gridUV
- Type: Autodesk.Revit.DBUV
Coordinates of a point in the rectangular grid of this compound structure.
- splitDirection
- Type: Autodesk.Revit.DBRectangularGridSegmentOrientation
Specifies the direction of the split.
- newSegmentId
- Type: SystemInt32%
The id of segment that bounds both the original region and the new region.
Return Value
The id of the region created by this operation.Remarks
This method is meant to be used in conjunction with FindEnclosingRegionAndSegments(UV, RectangularGridSegmentOrientation, Int32, Int32). Grid coordinates correspond to uv coordinates of faces.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.ExceptionsInvalidOperationException | Split and merge regions operations can be used only for vertically compound structures without variable thickness layers. |