SelectNewPrintDriver Method


Select a new printer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void SelectNewPrintDriver(
	string strPrinterName
)
Visual Basic
Public Sub SelectNewPrintDriver ( _
	strPrinterName As String _
)
Visual C++
public:
void SelectNewPrintDriver(
	String^ strPrinterName
)

Parameters

strPrinterName
Type: SystemString
The name string of new printer.

Remarks

This property is the global print setting property for all documents.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the input argument-strPrinterName-is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the assigned new printer is invalid, or the print resource is occupied by others.

See Also