ElementIntersectsElementFilter Constructor (Element)


Constructs a filter to match elements which intersect the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public ElementIntersectsElementFilter(
	Element element
)
Visual Basic
Public Sub New ( _
	element As Element _
)
Visual C++
public:
ElementIntersectsElementFilter(
	Element^ element
)

Parameters

element
Type: Autodesk.Revit.DBElement
The element to check for intersection.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also