AddVertices Method


Inserts multiple VertexStreamPositionNormal instances into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void AddVertices(
	IList<VertexPositionNormal> vertices
)
Visual Basic
Public Sub AddVertices ( _
	vertices As IList(Of VertexPositionNormal) _
)
Visual C++
public:
void AddVertices(
	IList<VertexPositionNormal^>^ vertices
)

Parameters

vertices
Type: System.Collections.GenericIListVertexPositionNormal
The vertices to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also