Exports the document to the Industry Standard Classes (IFC) format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: SystemString
Output folder into which the file will be exported. The folder must exist.
- name
- Type: SystemString
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
- options
- Type: Autodesk.Revit.DBIFCExportOptions
Various options applicable to the IFC format. If a null reference (Nothing in Visual Basic), all options will be set to their respective default values.
Return Value
True if successful, otherwise False.Remarks
Exporting to IFC requires that document is modifiable, therefore there must be a transaction already open when this method is called.
This method may not be invoked during dynamic update, for the internal routine might need to modify the existing transaction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | NullOrEmpty -or- Contains invalid characters. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsFileArgumentNotFoundException | The IFCExportOptions FamilyMappingFile does not exist. |
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException | This method may not be called during dynamic update. |
Autodesk.Revit.ExceptionsInvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. -or- This Document is not a project document. |
Autodesk.Revit.ExceptionsInvalidPathArgumentException | The folder does not exist. |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |
Autodesk.Revit.ExceptionsOptionalFunctionalityNotAvailableException | The IFC module is not available in the installed Revit. |