CurveElementFilter Constructor (CurveElementType)


Constructs a new instance of a filter to match specific types of curve elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public CurveElementFilter(
	CurveElementType curveElementType
)
Visual Basic
Public Sub New ( _
	curveElementType As CurveElementType _
)
Visual C++
public:
CurveElementFilter(
	CurveElementType curveElementType
)

Parameters

curveElementType
Type: Autodesk.Revit.DBCurveElementType
The curve element type to match.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also