BuildingType Property


The type of building.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public gbXMLBuildingType BuildingType { get; set; }
Visual Basic
Public Property BuildingType As gbXMLBuildingType
	Get
	Set
Visual C++
public:
property gbXMLBuildingType BuildingType {
	gbXMLBuildingType get ();
	void set (gbXMLBuildingType value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The building type does not fall within an appropriate range.
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration

See Also