Connects an air terminal to a duct directly (without the need for a tee or takeoff).
Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- airTerminalId
- Type: Autodesk.Revit.DBElementId
The air terminal id.
- ductCurveId
- Type: Autodesk.Revit.DBElementId
The duct curve id.
Return Value
True if connection succeeds, false otherwise.Remarks
The current location of the air terminal will be projected to the duct centerline, and if the point can be successfully projected, the air terminal will be placed on the most suitable face of the duct.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The familyinstance is not air terminal. -or- The element is not duct curve. -or- The air terminal already has physical connection. -or- The air terminal connector origin doesn't project within the center line of the duct. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |