Prompts the user to pick a point on the active work plane while showing a custom status prompt string.
Namespace: Autodesk.Revit.UI.Selection
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- statusPrompt
- Type: SystemString
Specifies the message shown on the status bar.
Return Value
The point picked by user.
Note: if the user cancels the operation (for example, through ESC), the method will throw an OperationCanceledException instance.
Remarks
Revit users will be permitted to manipulate the Revit view (zooming, panning, and rotating the view), but will not be permitted to click other items in the Revit user interface. Users are not permitted to switch the active view, close the active document or Revit application in the pick session, otherwise an exception will be thrown.
Note: this method must not be called during dynamic update, otherwise ForbiddenForDynamicUpdateException will be thrown.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the argument statusPrompt is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when no work plane set in current view. |
Autodesk.Revit.ExceptionsOperationCanceledException | Thrown when the Revit user cancelled this operation. Thrown when the Revit user tried to switch the active view, close the active document or Revit application when responding to this mode. |
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException | Thrown if this method is called during dynamic update. |