Label Property


The family parameter label of the BaseArray.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public FamilyParameter Label { get; set; }
Visual Basic
Public Property Label As FamilyParameter
	Get
	Set
Visual C++
public:
property FamilyParameter^ Label {
	FamilyParameter^ get ();
	void set (FamilyParameter^ value);
}

Remarks

The label associates the number of members of the array with a family parameter. A BaseArray only can be labeled in a family document and only can be labeled to a integer FamilyParameter. To unbind the family parameter, set this property to a null reference (Nothing in Visual Basic).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Thrown when the family parameter's ParameterType is not ParameterType.Integer.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when trying to label the BaseArray out of family document.

See Also