DiameterDimensionTypeId Property


Identifies the Id of the diameter dimension type which is used to show dimensions.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ElementId DiameterDimensionTypeId { get; set; }
Visual Basic
Public Property DiameterDimensionTypeId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ DiameterDimensionTypeId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The diameterDimensionTypeId should be an id of a diameter dimension type.
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also