MakeAdaptivePoint Method


Makes Reference Point an Adaptive Point or makes an Adaptive Point a Reference Point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static void MakeAdaptivePoint(
	Document doc,
	ElementId refPointId,
	AdaptivePointType type
)
Visual Basic
Public Shared Sub MakeAdaptivePoint ( _
	doc As Document, _
	refPointId As ElementId, _
	type As AdaptivePointType _
)
Visual C++
public:
static void MakeAdaptivePoint(
	Document^ doc, 
	ElementId^ refPointId, 
	AdaptivePointType type
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The Document
refPointId
Type: Autodesk.Revit.DBElementId
The ReferencePoint id
type
Type: Autodesk.Revit.DBAdaptivePointType
The Adaptive Point Type

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException This operation failed.

See Also