Creates a new topography surface element and adds it to the document.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to be modified.
- points
- Type: System.Collections.GenericIListXYZ
A collection of points. The points represent an enclosed area in the XY plane. There can be only one point in the same XY location.
Return Value
The new topography surface.Remarks
The document will be regenerated during the creation of this topography surface element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | document is not a project document. -or- There are no points in the input points set. -or- There were not enough points to form a valid region (at least 3 are required), or the points were collinear ignoring elevation. -or- One or more points shared the same XY location (even with different elevations). This is not permitted for topography surfaces. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |