Creates a fabrication part element based on button and size.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- button
- Type: Autodesk.Revit.DBFabricationServiceButton
The fabrication service button to use. Matches button condition based on the specified size.
- width
- Type: SystemDouble
The width of the part. Units are in feet (ft).
- depth
- Type: SystemDouble
The depth of the part. Units are in feet (ft). It should be equal to width for round part.
- levelId
- Type: Autodesk.Revit.DBElementId
The element identifier associated with the Level the FabricationPart will be created on.
Return Value
The new fabrication part.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Fabrication service button contains invalid fittings. -or- Please use FabricationPart.CreateHanger to create fabrication hanger. -or- The ElementId levelId is not a Level. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The fabrication part type does not exist. Reload the service using FabricationConfiguration.LoadServices. -or- failing to match a button condition based on specific size. |