Create an instance of a schedule on a sheet.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document
- viewSheetId
- Type: Autodesk.Revit.DBElementId
The id of the sheet where the schedule will be placed.
- scheduleId
- Type: Autodesk.Revit.DBElementId
The id of the schedule view.
- origin
- Type: Autodesk.Revit.DBXYZ
Location on the sheet where the schedule will be placed.
Return Value
The new ScheduleInstance.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | scheduleId is not a ViewSchedule that can be added to sheets. "Internal" schedules are not user-visible but are filtered by sheet or used to manage Revisions, which cannot be added to sheets. -or- viewSheetId is not a ViewSheet. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |