Returns true if the gemetrical targets (ex. face references, other rebar segment references) of "this" constriant are the same as the targets of the "other" constraint. Returns false otherwise. Only the reference to the target piece of geometry is taken into account(ex. only face references, only other rebar segment references). Target Element (elementId) is not taken into account. Distance to target is not taken into account.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- otherConstraint
- Type: Autodesk.Revit.DB.StructureRebarConstraint
Returns the Element object (either Host or Rebar) which provides the constraint.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | RebarConstraint is no longer valid. |