Add a new family type parameter to control the type of a nested family within another family.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameterName
- Type: SystemString
The name of the new family parameter.
- groupTypeId
- Type: Autodesk.Revit.DBForgeTypeId
The identifier of the group to which the family parameter belongs.
- familyCategory
- Type: Autodesk.Revit.DBCategory
The category to which the new family parameter binds.
- isInstance
- Type: SystemBoolean
Indicates if the new family parameter is instance or type.
Return Value
If creation was successful the new parameter is returned, otherwise an exception with failure information will be thrown.Remarks
This method can work even without any family type, but it cannot be assigned the value via FamilyManager.Set methods when there is no current type.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument-"parameterName"-is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the input argument-"parameterName"-is already in use, or the input parameter group cannot be assigned to the new parameter, or the input argument-"familyCategory"-is illegal to bind with parameter. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the required family of familyCategory is not existing in current document, , or when the creation failed. Or trying to add an instance parameter of image type. |