ModifySubElement Method (SlabShapeVertex, Double)


Manipulates the vertex on the corresponding slab, roof or floor.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void ModifySubElement(
	SlabShapeVertex vertex,
	double offset
)
Visual Basic
Public Sub ModifySubElement ( _
	vertex As SlabShapeVertex, _
	offset As Double _
)
Visual C++
public:
void ModifySubElement(
	SlabShapeVertex^ vertex, 
	double offset
)

Parameters

vertex
Type: Autodesk.Revit.DBSlabShapeVertex
The vertex.
offset
Type: SystemDouble
The new value of the vertex offset.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when the vertex is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when the vertex is invalid.

See Also