RemoveTemperatureRatingType Method


Remove an existing temperature rating type from this material type.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveTemperatureRatingType(
	TemperatureRatingType temperatureRating
)
Visual Basic
Public Sub RemoveTemperatureRatingType ( _
	temperatureRating As TemperatureRatingType _
)
Visual C++
public:
void RemoveTemperatureRatingType(
	TemperatureRatingType^ temperatureRating
)

Parameters

temperatureRating
Type: Autodesk.Revit.DB.ElectricalTemperatureRatingType
The temperature rating type to be removed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException The last temperature rating type of project and any one used by a wire type can't be removed.

See Also