Create a cylindrical helix.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- basePoint
- Type: Autodesk.Revit.DBXYZ
Base point of the axis. It can be any point in 3d.
- radius
- Type: SystemDouble
Radius. It should be a positive number.
- xVector
- Type: Autodesk.Revit.DBXYZ
X vector. Should be Non-zero vector.
- zVector
- Type: Autodesk.Revit.DBXYZ
Z vector = axis direction. Should be non-zero and orthogonal to X Vector.
- pitch
- Type: SystemDouble
Pitch. It should be non-zero number, can be positive or negative. Positive means right handed and negative means left handed.
- startAngle
- Type: SystemDouble
Start angle. It specifies the start point of the Helix.
- endAngle
- Type: SystemDouble
End angle. It specifies the end point of the Helix. End angle should not be equal to start angle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The radius is negative -or- the pitch is zero -or- the xVector or zVector is zero length -or- zVector is not orthogonal to xVector -or- endAngle is equal to startAngle. |